Odpowiedz 
 
Ocena wątku:
  • 0 Głosów - 0 Średnio
  • 1
  • 2
  • 3
  • 4
  • 5
Problemy :)
09-02-2015, 10:16 PM
Post: #1
Problemy :)
Witam, chciałem zacząć naukę Androida, więc zacząłem wg. poradnika. Natknąłem się jednak na kilka błędów które już przedstawiam. Pobrałem z oficjalnej strony Eclipse Juno tak jak było w poradniku, jdk i android-studio. Poźniej pobrałem do sdk wersje androida 5.1.1 bo na takim miałem zamiar coś robić. (błąd pierwszy) Za każdym uruchomieniem Eclipse dostaje takie errory

Cytat:[2015-09-02 23:09:06 - Android SDK] Error when loading the SDK:

Error: Error parsing C:\Users\Wojciech Dudziński\AppData\Local\Android\sdk\system-images\android-22\android-wear\armeabi-v7a\devices.xml
cvc-complex-type.2.4.d: Invalid content was found starting with element 'd:skin'. No child element is expected at this point.
Error: Error parsing C:\Users\Wojciech Dudziński\AppData\Local\Android\sdk\system-images\android-22\android-wear\x86\devices.xml
cvc-complex-type.2.4.d: Invalid content was found starting with element 'd:skin'. No child element is expected at this point.
Nie za bardzo wiem co zrobić, próbowałem odinstalować tą wersje androida ale nic nie dało.
(błąd drugi)

jak mam tą aplikację jaka jest na poradniku i kolejno wchodzę w res\layout\activiti_main i próbuje go uruchomić na tej wirtualnej maszynie czy czymś tam Smile to NIC się nie dzieje. Próbowałem na różne sposoby i nie wiem co z tym zrobić. Proszę o wyrozumiałość jeżeli coś źle napisałem, ale jestem amatorem. Dziekuję Smile
Znajdź wszystkie posty użytkownika
Odpowiedz cytując ten post
09-03-2015, 06:41 AM
Post: #2
RE: Problemy :)
Witam,
1. Lepiej zainstaluj Android Studio bo Eclipse to straszne dziadostw.
2. Posiadasz telefon z Androidem? Jeśli tak to jaka wersja?
3. Jak to próbujesz uruchomić? Wirtualna maszyna się otwiera i nic? Aplikacja instaluje się na niej?

GG: 2802571
Znajdź wszystkie posty użytkownika
Odpowiedz cytując ten post
09-03-2015, 08:02 PM
Post: #3
RE: Problemy :)
Posiadam telefon z androidem 5.0.1 na razie.
no gdy wejdę w ten plik res\layout\activiti_main to klikam na górnym pasku narzędzi RUN i dalej wybieram jak uruchomić, więc biorę android(coś tam ) i nie dzieje się kompletnie nic, żadnej reakcji po jakimkolwiek czasie.
A co myślisz jeżeli chodzi o ten błąd przy starcie? z tym błędem odczytania sdk?
Znajdź wszystkie posty użytkownika
Odpowiedz cytując ten post
09-03-2015, 08:37 PM
Post: #4
RE: Problemy :)
Problemem mogą być polskie znaki dialektyczne w ścieżce.
Szczerze to nie rozumiem tego masochizmu jakim jest używanie Eclipsa, nie rozumiem dlaczego ludzie tak się nienawidzą i używają tego syfu.
Radzę zamiast używać emulatora skorzystać z telefonu tylko musisz albo zainstalować na telefonie nowszego androida albo zacząć pisać na androida 5.0.x

GG: 2802571
Znajdź wszystkie posty użytkownika
Odpowiedz cytując ten post
09-04-2015, 09:46 PM
Post: #5
RE: Problemy :)
co do eclipse to jak było napisane w poradniku java start tam gdzie android Smile wiec chciałem iść jak karzą a np IntellJ sie nie nada? używam go aktualnie do javy
Znajdź wszystkie posty użytkownika
Odpowiedz cytując ten post
09-06-2015, 12:04 PM
Post: #6
RE: Problemy :)
Android Studio jest oparty na IntelliJ więc możesz użyć zwykłego IntelliJ i tylko spiąć z sdk androidowym

GG: 2802571
Znajdź wszystkie posty użytkownika
Odpowiedz cytując ten post
Odpowiedz 


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości